Заметки сисадмина о интересных вещах из мира IT, инструкции и рецензии. Настраиваем Компьютеры/Сервера/1С/SIP-телефонию в Москве

Как запускать старые программы, расчитанные на Win9x/NT4.0 под W2k?

2007-04-27 · Posted in Windows - 2000

Специально для этого Microsoft включила в состав дистрибутива утилиту apcompat.exe (находится в директории \SUPPORT). При запуске программы из-под нее можно имитировать запуск под Windows NT 4.0 (SP3,4,5), Windows 95, 98. Есть дополнительные опции. Hо не все программы удается обмануть таким образом.

Подробнее читайте здесь: http://www.microsoft.ru/catalog/article.asp?article_ID={CE6FA157-3FC2-11D4-A6D1-00508B8B783F}. Кроме того, существует Application Compatibility Update, скачать который можно с сайта Microsoft, зайдя по адресу http://www.microsoft.com/windows2000/downloads/tools/appcompat/default.asp или здесь: http://www.chem.univ.kiev.ua/~adsh/win2k/soft/appupd.php (для Украины: http://www.adsh.kiev.ua/win2k/soft/appupd.zip). После его установки в свойствах ярлыка исполняемых файлов появляется закладка "Compatibility" (только под аккаунтом администратора!), в которой можно выбрать режим запуска приложения. Эта возможность включена в пакет обновлений, начиная с Service Pack 2.

(!) Чтобы включить закладку "Compatibility" (при её отсутствии), после установки Service Pack 2 и перезагрузки нужно дать в консоли команду: regsvr32 %systemroot%\apppatch\slayerui.dll. Удалить эту закладку при желании можно командой regsvr32 /u %systemroot%\apppatch\slayerui.dll.

Leave a Reply