Заметки сисадмина о интересных вещах из мира IT, инструкции и рецензии. Настраиваем Компьютеры/Сервера/1С/SIP-телефонию в Москве

После конвертации конфигурации из 7.5 в 7.7 выдается ошибка при переходе внутрь цикла Пока по метке. Почему в версии 7.7 такой переход не работает?

2007-04-30 · Posted in Общие вопросы

Это особенность встроенного языка версии 7.7. Она описана в файле 1c75_77.txt, входящем в поставку версии 7.7.
В версии 7.7
введены дополнительные ограничения на использование оператора безусловного перехода "Перейти" для предотвращения ошибочных ситуаций.
Оператор безусловного перехода "Перейти" ("Goto") не может быть использован для передачи управления на операторы, находящиеся внутри конструкций:
"Пока… КонецЦикла"
"Для… КонецЦикла"
"Если… ИначеЕсли… Иначе… КонецЕсли".

Leave a Reply